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1. Introduction 

The Centellax PPG12500 Programmable Pattern Generator (PPG) has 24Mbits of 
programmable pattern memory. The PPG12500 includes many telecom and datacom 
preloaded RAM patterns, including CRPAT, CJPAT, K28-3, K28-5, K28-7, and PRBS 2N 
[N = 7, 10, 11, 13, 15, 23]. The Centellax Pattern Utility Software allows users to create 
and upload their own custom patterns onto the PPG12500 for playback. 

 

 

Figure 1 User pattern to high-speed data 

 

Features: 

 Create custom patterns in binary or hexadecimal format 

 Check syntax of custom patterns to ensure file integrity 

 Save pattern files to PC disk drive 

 Upload custom patterns to a PPG12500 Programmable Pattern Generator 

 Manage custom patterns on a PPG12500 Programmable Pattern Generator 
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2. Installation 

Download the software from www.centellax.com or access the software from the CD that 
was shipped with the PPG12500. 

Save the file to a temporary location (for example, C:/temp). 

Double-click the following file from Windows Explorer: 

e.g. C: /temp/setup.exe 

Follow the on-screen installation instructions. 

If upgrading an already installed version of the Centellax Pattern Utility Software, it is 
recommended to first uninstall the original version, then install the new version. 
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3. Creating Patterns – the Editor Window 

3.1. File Format 

A pattern file can be made up of either binary or hexadecimal data, but not both.  
In binary pattern mode, only characters in the following set are allowed in the pattern 
data: 

 0-1 

In hexadecimal pattern mode, only characters in the following sets are allowed in the 
pattern data: 

 0-9 

 a-f 

 A-F 

The pattern file extensions allowed are: 

 For files in binary format =  <filename>.bpt 

 For files in hexadecimal format = <filename>.hpt 

The most significant bit on the first line of the pattern file is the first bit generated in the 
serial pattern. The right most bit of the last line of the pattern file will be the final bit 
generated in the serial pattern. 

The PPG12500 can play back custom user patterns up to 24Mbits long (25165824 bits). 
The length of the pattern file that is ultimately stored in PPG12500 memory must be 
exactly divisible by 128 and be a minimum of 256bits long. If the pattern length created in 
the Centellax Pattern Utility Software is not divisible by 128 and at least 256 bits long, 
then the pattern will be replicated until it meets these conditions. In some cases, the 
replicated pattern created may not fit in the available amount of PPG12500 memory. In 
such a case, an error message will be generated requesting that the pattern be modified to 
meet the pattern length requirements. Refer to Figure 2. 

 

Figure 2 Error message if replicated pattern exceeds memory size 
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The PPG12500 Programmable Pattern Generator requires filenames to be in a DOS 8.3 
format, with .usr as the file extension e.g. testpatt.usr.  Pattern files stored on a Windows 
PC with a .hpt or .bpt file extension do not need to conform to the 8.3 format. 

3.2. Create/Edit File 

The Centellax Pattern Utility Software user provides the interface to create custom user 
patterns for the PPG12500 Programmable Pattern Generator. Figure 3 shows the text 
window used for entering pattern data.  

 

Figure 3 Pattern edit window 
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When the Centellax Pattern Utility Software is launched, it first scans the host PC’s USB 
interfaces to detect PPG12500 instruments available for connection to the utility. If a 
PPG12500 is not detected then the window in Figure 4 is displayed. Pressing OK allows 
the user to continue and create/edit patterns without PPG12500 being connected. These 
patterns can be stored to the PC for later uploading to a PPG12500.  

 

Figure 4 No instruments connected 

If one or more PPG12500 instruments are detected then a window similar to Figure 5 is 
displayed, listing the serial number of each instrument. Select the appropriate PPG12500 
from the list available, and click OK to continue.  

 

Figure 5 Connected instrument list 

000012345 
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The Centellax Pattern Utility Software allows a description of up to 256 characters to be 
entered in the description window to describe the custom pattern. Comments are not 
allowed in the pattern edit window. Refer to Figure 6. 

 
Figure 6 Pattern description field 

Each line in the pattern edit window may contain up to 1000 characters. If the Centellax 
Pattern Utility Software detects more than 1000 characters per line during a file open 
command or cut and paste operation, the line will be wrapped to the next line in the 
pattern edit window. 

The Centellax Pattern Utility Software allows the numeric base of the pattern 
data to be toggled between hexadecimal and binary format by clicking on the               icon 
or selecting ‘Tools->Bin/Hex’. The default numeric base for the pattern data is binary. 
Clicking once toggles the numeric base from binary to hexadecimal. Clicking once more 
toggles back from hexadecimal to binary. This action will also reformat the display in the 
pattern edit window to be a maximum of 32 bits per line in binary mode, and a maximum 
of 8 characters per line in hexadecimal mode. 

If a binary file does not contain a total number of bits that is divisible by 4 then it cannot 
be displayed in hexadecimal format and an error message will be generated. Refer to 
Figure 7. 
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Figure 7 Binary to hexadecimal conversion error 

Data can be directly typed into the pattern edit window in either binary or hexadecimal 
format, or data can be pasted into the window from another application. The total pattern 
length in bits is displayed at the bottom of the pattern edit window, together with the 
current x-y position of the cursor. Refer to Figure 8. 

 

Figure 8 Pattern length display 

 
To clear the current pattern from the editor and start a new pattern, select ‘File->New’ or 

click the  icon. A warning message as shown in Figure 9 will be displayed to help 
prevent accidently clearing the current patter. Click Yes to continue or No to cancel the 
operation. 
 

 
Figure 9 Clear pattern confirmation 
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3.3. Save Pattern File 

The Centellax Pattern Utility Software can save custom user patterns in either binary or 
hexadecimal file format and will automatically assign a .bpt or .hpt file extension based on 
the current pattern mode. To save a file select ’File->Save’ or ’File->Save As’ or click the 

 icon and navigate to the desired location. Refer to Figure 10. 

 

Figure 10 File Save window 

3.4. Open Pattern File 

The Centellax Pattern Utility Software can open custom user patterns previously created 
by this utility or also patterns created in an external text editor. To open a file select  

’File->Open’ or click the  icon. If the current pattern has not been saved then a 
warning message as shown in Figure 11 will be displayed. Click Yes to save the current 
pattern first, or No to continue with pattern open command. 

 

Figure 11 Save pattern warning 
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The ’File->Open’ or clicking on the  icon brings a window similar to that shown in 
Figure 12. Select “Binary Pattern Files (*.bpt)”, “Hexadecimal Patten Files (*.hpt)”, or “All 
Files (*.*)” as appropriate to display just the binary or hexadecimal patterns or all files in 
the current directory. Select the appropriate pattern to load and click Open. 

 

 

    

Figure 12 File open windows 
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A binary pattern file (*.bpt) containing non-binary data will cause an error to occur upon 
opening. The error message displayed is similar to that shown in Figure 13. 

 

Figure 13 Binary pattern file open error message 

A hexadecimal pattern file (*.hpt) containing non-hexadecimal data will cause an error to 
occur upon opening. The error message displayed is similar to that shown in Figure 14. 

 

Figure 14 Hexadecimal pattern file open error message 

The Centellax Pattern Utility Software will detect the numeric base of the pattern based 
on the file extension, and select the correct mode, binary or hexadecimal for the editor. If a 
pattern with a different file extension is loaded (e.g. .txt file) then the current edit mode 
will be retained. 

3.5. Syntax Checking 

Pattern structure and syntax must be checked before a pattern is uploaded to the   
PPG12500. There are several ways to perform a syntax check of the created or imported 
pattern file. 

1 A syntax check is performed when a custom user pattern is loaded into the Centellax 
Pattern Utility Software. 

2 Select ’Tools->Check Syntax’ to check the syntax of the pattern data in the edit 
window. 

3 Selecting ’Tools->Upload Pattern’, or click the  icon. A syntax check is performed 
before uploading a pattern to the PPG12500. 
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3.6. Upload Pattern File 

Once the pattern data passes the syntax checking it is ready to be uploaded to a 
PPG12500 Programmable Pattern Generator. 

The Centellax Pattern Utility Software scans the host PC’s USB interfaces to detect 
PPG12500 instruments available for connection to the utility. If a PPG12500 is not 
detected then pattern upload is not possible and the upload icon  and ‘Tools->Upload 

Pattern’ items will be grayed out on the utility window. Refer to Figure 15. 

 

Figure 15 No instruments connected 

If the target PPG12500 is connected to the PC via the USB interface but not currently 
connected to the Centellax Pattern Utility Software, then connect the target PPG12500 by 
selecting ‘Tools->Select Instrument’ and then selecting the PPG12500 from the list of 
available instruments in the Centellax Instrument List window, by choosing the 
instrument with the serial number that matches the target PPG12500. Refer to Figure 16.  

  

Figure 16 Centellax Instrument List window 

Once the target PPG12500 is connected to the Centellax Pattern Utility Software, then 
select ‘Tools->Upload Pattern’ or click the  icon to upload the current pattern to the 
PPG12500.  

000012345 
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The Centellax Pattern Utility Software will first check to see if there is sufficient space on 
the target PPG12500 for the user pattern. If there is insufficient space an error message 
will be displayed and the uploaded cancelled. 

If the current pattern has not been saved to the PC hard disk, the user will be prompted 
to save the file first before uploading to the PPG12500. Refer to Figure 17. 

 

Figure 17 Pattern save warning 

If the current pattern file has a filename longer than 8 characters, a dialog similar to 
Figure 18 will be displayed. The PPG12500 requires filenames in a DOS 8.3 format, e.g. 
TESTPATT.USR. The 3 character file extension need not be entered as all user patterns 
uploaded to the PPG12500 are assigned .usr file extension. Only characters in the 
following sets are allowed in the PPG12500 filename: 

 a-z 

 A-Z 

 0-9 

 Underscore ‘_’  and minus ‘-‘ symbols 

 

Figure 18 Pattern name dialog window 
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During the pattern upload, a progress bar will be displayed to track the time until 
completion. If the pattern file is uploaded successfully, a message will be displayed. Refer 
to Figure 19. Most patterns will load within a short time, however a pattern utilizing the 
entire 32Mbit memory can take approx 30minutes to transfer to the PPG12500. 

 

Figure 19 Pattern upload in progress window 

Once a pattern has been successfully uploaded to the PPG12500, use the Pattern Select 
menu on the PPG12500 to select the uploaded pattern as the active pattern on the    
PPG12500. 

3.7. Exit Application 
 
To exit the Centellax Pattern Utility Software application select ‘File->Exit’. If the current 
pattern has not been saved to the PC hard disk, the user will be prompted to save the file 
first before exiting the Centellax Pattern Utility Software application. Refer to Figure 20. 
 

 
Figure 20 Pattern save warning on exit 
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4. Managing Patterns – the Pattern List Window 

4.1. Pattern List 
 
When the target PPG12500 is selected from the Centellax Instrument List, then a list of 
all the patterns available on the target PPG12500 is displayed on the Pattern List 
window. Refer to Figure 21.  
 
Patterns in this list with a .fpt file extension (e.g. PN7_4-8.FPT) are factory loaded RAM 
patterns within the PPG12500. These patterns are listed for information purposes only. 
 
Patterns in this list with a .usr file extension (e.g. 1_90.USR) are user patterns that have 
been loaded into the PPG12500 using the Centellax Pattern Utility Software. 
 

 
 

Figure 21 Pattern list window 
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4.2. Delete Pattern 
 
Only .usr user patterns can be deleted from the target PPG12500. To delete a user 

pattern, select it from the list and click on the  button. 
 
A confirmation message as shown in Figure 22 will be displayed. Click Yes to continue with 
the pattern delete or click No to cancel the operation. 
 

 
Figure 22 Delete pattern confirmation 

 
Attempts to delete factory patterns will generate an error message as shown in Figure 23. 
 

 
Figure 23 Pattern delete error message 

 


